Web Print is intermittently unavailable
Incident Report for SeattleU IT Services
Resolved
Web Print is functioning properly. It has been tested and validated to be working.
Posted Apr 07, 2022 - 13:30 PDT
Investigating
At this time, Web Print is intermittently unavailable. All other services are available. Updates will be provided as they are available.
Posted Apr 07, 2022 - 12:26 PDT
This incident affected: Printing (Managed Print Services).