Student Account Center outage
Incident Report for SeattleU IT Services
Resolved
The issue with Student Account Center has been resolved. Thank you for your patience.
Posted Jan 12, 2024 - 15:37 PST
Investigating
We are aware of issues logging into Student Account Center (Touchnet). We will post once the issue is resolved. Thank you for your patience.
Posted Jan 12, 2024 - 11:48 PST
This incident affected: Other.