Zoom Meetings Outage

Incident Report for SeattleU IT Services

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 15:07 PDT

Update

Zoom reports that the Admin portal and Zoom meetings are operational.
Posted Apr 16, 2025 - 15:06 PDT

Investigating

Zoom is currently investigating this issue: https://status.zoom.us/
Posted Apr 16, 2025 - 12:47 PDT
This incident affected: Zoom Meetings.