Power Outage at BELL and PAVL
Incident Report for SeattleU IT Services
Resolved
Power has been restored to both locations.
Posted Feb 08, 2022 - 08:14 PST
Investigating
There is a power outage at the BELL and PAVL locations. This will impact the network at these locations, including both wired and wireless connections. This is being investigated. Please check StatusPage for updates regarding this.
Posted Feb 07, 2022 - 16:34 PST
This incident affected: Network (wired/wireless, internet) and Other.