Email Slowness/Connectivity Problems
Incident Report for SeattleU IT Services
Resolved
We are no longer seeing performance issues and have confirmed with Microsoft that the system is back to normal.

We appreciate your patience!
Posted Jun 08, 2023 - 08:46 PDT
Monitoring
Microsoft's latest update:

We continue to observe stable service health since we've applied our various preemptive mitigations and we will closely monitor the service should there be a recurrence.

Seattle U Service Desk is monitoring the updates from Microsoft and will provide updates in a timely manner. Thanks for your patience!
Posted Jun 06, 2023 - 21:41 PDT
Investigating
Latest Update from Microsoft:

We’ve identified that the impact has started again, and we’re applying further mitigation. Telemetry indicates a reduction in impact relative to earlier iterations due to previously applied mitigations.

Seattle U Service Desk is monitoring the updates from Microsoft and will provide updates in a timely manner. Thanks for your patience!
Posted Jun 06, 2023 - 10:36 PDT
Monitoring
Latest update from Microsoft:

We've confirmed that service availability has returned to healthy levels. We'll continue to monitor service health while we analyze system logs to determine the cause of the problem.
Seattle U Service Desk is monitoring the updates from Microsoft and will provide updates in a timely manner. Thanks for your patience!
Posted Jun 05, 2023 - 17:56 PDT
Identified
Update from Microsoft:

We're implementing some changes intended to improve the user experience and will closely monitor to ensure these changes deliver the desired effect.
Seattle U Service Desk is monitoring the updates from Microsoft and will provide updates in a timely manner. Thanks for your patience!
Posted Jun 05, 2023 - 15:09 PDT
Update
Update from Microsoft:

We're currently analyzing error patterns to understand what factors are contributing to the issue. In parallel, we're investigating more immediate actions that can be taken to provide relief to users.

Seattle U Service Desk is monitoring the updates from Microsoft and will provide updates in a timely manner. Thanks for your patience!
Posted Jun 05, 2023 - 14:38 PDT
Update
We are continuing to monitor this issue and will provide timely updates.
Posted Jun 05, 2023 - 13:57 PDT
Investigating
Microsoft Exchange is having performance issues again as of 1:15 pm. Microsoft is looking into the issues but has not yet provided a cause or restoration timeline. Services impacted are Exchange and Outlook on the web, Microsoft Teams, SharePoint Online, and OneDrive for Business.
Posted Jun 05, 2023 - 13:38 PDT
Monitoring
Microsoft has reverted the update (which caused the issue) and telemetry shows service improvement. They are continuing to monitor the service to ensure recovery and performing actions to address any residual impact.
Posted Jun 05, 2023 - 09:34 PDT
Investigating
Microsoft Exchange is having performance issues this morning. Microsoft is looking into the issues but has not yet provided a cause or restoration timeline. New emails are taking several minutes to load into the various Outlook clients.
Posted Jun 05, 2023 - 09:25 PDT
This incident affected: Microsoft 365.