Canvas Studio and DocViewer Experiencing Issues
Incident Report for SeattleU IT Services
Resolved
This has been resolved.
Posted Apr 28, 2022 - 15:08 PDT
Investigating
Canvas is currently experiencing issues with Studio and DocViewer. The vendor is aware and working on the issue. We will provide updates as they come available.
Posted Apr 28, 2022 - 08:34 PDT
This incident affected: Canvas.