SU-secure is temporarily unavailable
Incident Report for SeattleU IT Services
Resolved
SU-secure is now available. Apple iOS devices, including iPhones and iPads, will present a message asking the user to trust the new certificate from oitias1.seattleu.edu (expiration 7/26/2025). Android devices may or may not display a similar message; depending on the device type and OS.
Posted Jul 08, 2024 - 08:38 PDT
Investigating
"SU-secure is temporarily unavailable for some wireless devices. ITS is working to resolve the issue"
Posted Jul 08, 2024 - 08:20 PDT
This incident affected: Network (wired/wireless, internet).