Colleague UI, mySeattleU, and SUOnline Access Issues
Incident Report for SeattleU IT Services
Resolved
We are seeing that all Colleague services, including mySeattleU and SUOnline, are working as expected now. We are working with Ellucian to identify the issue that impacted access and will continue to closely monitor these systems. If you experience any further issues, please contact the IT Service Desk at servicedesk@seattleu.edu or 206-296-5571. Thank you!
Posted Feb 17, 2022 - 11:34 PST
Investigating
We are seeing issues with access to Colleague UI, mySeattleU, and SUOnline. We are aware that this is impacting spring quarter registration that is underway this week. We are working with Ellucian, our vendor partner to address this issue and will post updates as we have them. Thank you for your patience.
Posted Feb 17, 2022 - 11:20 PST
This incident affected: Colleague, mySeattleU, and SUOnline.