MySeattleU Performance Issues
Incident Report for SeattleU IT Services
Resolved
We are no longer seeing issues with performance on MySeattleU.
Posted Nov 12, 2024 - 14:45 PST
Monitoring
We are no longer experiencing performance issues but will continue to monitor performance closely over the next several hours.
Posted Nov 12, 2024 - 12:23 PST
Update
Performance appears to be improving. We are continuing to work with our vendor to be sure that it will not degrade again.
Posted Nov 12, 2024 - 11:54 PST
Investigating
We are currently seeing significant performance issues with my.seattleu.edu. Performance has slowed to a point that services appear to be unavailable or take a significant amount of time to load. We have opened a ticket with our vendor and are working to address the issue.
Posted Nov 12, 2024 - 11:45 PST
This incident affected: mySeattleU.