Student Account Center (Touchnet) is Down
Incident Report for SeattleU IT Services
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 13:32 PST
Investigating
The Touchnet hosted Student Account Center is currently experiencing an outage. We are working with the vendor to identify and resolve the solution.
Posted Nov 08, 2024 - 13:03 PST
This incident affected: Other.