Softdocs outage
Incident Report for SeattleU IT Services
Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 08:30 PST
Investigating
When visiting Softdocs Etrieve Suite, the error "There was an unexpected error" appears. We are investigating this issue with the vendor.
Posted Jan 05, 2022 - 08:10 PST
This incident affected: Softdocs.