University call centers are unable to accept calls
Incident Report for SeattleU IT Services
Resolved
This issue has been resolved.
Posted Jun 30, 2022 - 10:33 PDT
Investigating
Cisco Finesse, the system used by university call centers to receive phone calls, is currently down. This will prevent callers from being able to call into call centers across campus, including Service Desk. ITS is currently working with the vendor to resolve this issue.
Posted Jun 30, 2022 - 09:30 PDT
This incident affected: Other.