Admissions Funnel and Graduate Admission Funnel Blank YTD Data
Incident Report for SeattleU IT Services
Resolved
This incident has been resolved.
Posted Jan 03, 2022 - 08:43 PST
Investigating
The Admissions Funnel and Graduate Admissions Funnel reports are showing blank data for YTD columns. We are investigating the issue.
Posted Jan 03, 2022 - 08:09 PST
This incident affected: InformSU.