Degraded Performance in Confluence Cloud

Incident Report for SeattleU IT Services

Resolved

Resolved - Between 09/18 10:47 UTC to 09/19 04:15 UTC, we experienced degraded performance for some Confluence, Jira Work Management, Jira Service Management, Jira Software, Trello, Atlassian Access, and Jira Product Discovery customers. The issue has been resolved and the service is operating normally.
Posted Sep 19, 2023 - 07:45 PDT

Update

We are continuing to investigate this issue.
Posted Sep 19, 2023 - 07:44 PDT

Update

Update from Atlassian:

An outage with a cloud provider is impacting multiple Atlassian Cloud products including Access, Confluence, Trello, and Jira Products. We will provide more details within the next hour.
Posted Sep 18, 2023 - 14:27 PDT

Investigating

Update from Atlassian:

Investigating - We are investigating an issue with Confluence loading slowly or failing to load, impacting some Confluence Cloud customers. We will provide more details within the next hour.
Posted Sep 18, 2023 - 11:23 PDT
This incident affected: Other.