Slate Student CRM
Incident Report for SeattleU IT Services
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 15:40 PDT
Investigating
A number of users are reporting a slow response from the application. We are investigating the matter and reaching out to the vendor.
Posted Sep 27, 2022 - 09:51 PDT
This incident affected: Slate.