mySeattleU Not Displaying Information
Incident Report for SeattleU IT Services
Resolved
The issue with mySeattleU is now resolved. We will continue to monitor the service. If you encounter any issues, please contact the IT Service Desk at servicedesk@seattleu.edu or 206-296-5571. Thank you!
Posted Jan 30, 2023 - 16:17 PST
Investigating
We are seeing an issue with mySeattleU where the service is there, but pages are not returning the information expected (e.g., Earnings Statements, Time Approval, etc.). Colleague UI appears to be functioning normally. We have opened a P1 ticket with Ellucian, the vendor, and will post updates as we have them. Thank you for your patience!
Posted Jan 30, 2023 - 15:40 PST
This incident affected: mySeattleU.