Slate/Technolutions has reported database connectivity issues that have impacted logins and access.

Incident Report for SeattleU IT Services

Resolved

This incident has been resolved.
Posted Apr 12, 2022 - 13:27 PDT

Investigating

We are currently investigating this issue.
Posted Apr 12, 2022 - 13:16 PDT
This incident affected: Slate.